FATAL Failed to start server: Unable to run instance IP:PORT

One of the more common crashes encountered when first setting up a node is …
Failed to start server: Unable to run instance: unable to contact local address: IP:PORT

The solution to this is to enable the overrideInternalIP flag in the cmix.yaml file on the node computer.

$ nano /opt/xxnetwork/config/cmix.yaml

Find the following section …

   # If set, then it is used to override the internal IP address used to contact
   # yourself. Expects an IPv4 address with or without a port. If no port is
   # included, then the port from the port flag is used.
   # WARNING: Do not modify this option unless explicitly required.
   #overrideInternalIP: "127.0.0.1"

All you should need to do is remove the # to uncomment the flag. You do not need to change the IP address and please make sure not to remove any preceding spaces. Just delete the # so it stays lined up like as follows.

   # If set, then it is used to override the internal IP address used to contact
   # yourself. Expects an IPv4 address with or without a port. If no port is
   # included, then the port from the port flag is used.
   # WARNING: Do not modify this option unless explicitly required.
   overrideInternalIP: "127.0.0.1"

Save the file by pressing Ctrl+s then Ctrl+x

Restart the cmix service
$ sudo systemctl restart xxnetwork-cmix

2 Likes