Cuda 11 OK?

Hi, late night blunder - installed cuda 11 instead of 10.2 as mentioned in the BetaNet handbook. Will 11 work, or is it only 10.2 that should be in place?
Thanks!

1 Like

Without having tried or tested our software with CUDA 11 it’s probably best if you downgrade to 10.2.

2 Likes

Got it, thanks!

Here to report that Cuda 11 does not work. You need 10.x. I downgraded as per this post and now my GPU works.

2 Likes

Strange, i run a node with Ubuntu 20.04 and Cuda11 all working fine. also verified with discord group. @Swader where did you see soemthing is off?

The node was just failing to start the GPU process and said it was falling back to CPU mode. It was resolved as soon as I downgraded to 10.x.

https://dashboard.xx.network/nodes/JTXVJr3pZQ8M4HkN+9AJ4wvnJ6dYzfbyVxThsid8c54C <-- thats my node… maybe i have to do a writeup …

Not sure then. I’ll do some more tests once I’ve set up monitoring. Writeup coming up.

just to show that the cpu useage is near 0 and the xx-node thread is running on the gpu. with around 55% useage

Nice. What CPU? I’m at around 8% with spikes of 20% on a Ryzen 9 3900x. GPU (2080 RTX) is at 40%.

— NODE —

[email protected]:~# cat /proc/cpuinfo | grep “model name” | tail -n 1
model name : AMD Ryzen 7 3700X 8-Core Processor

Here is my load:
[email protected]:~# w
14:06:21 up 3 days, 17:55, 1 user, load average: 0.83, 0.47, 0.25

— GW —

[email protected]:~# cat /proc/cpuinfo | grep “model name” | tail -n 1
model name : Intel® Core™ i7-6600U CPU @ 2.60GHz

[email protected]:~# w
14:08:35 up 3 days, 17:57, 1 user, load average: 0.62, 0.55, 0.45

Update: do not use Cuda 11.0 … since around 48h my node got to 24% failure rate… i had to do a complete re-install back to 10.2.

I’m still with Cuda 11 and Nvidia driver 455.60 work fine until now.
Rollback to 10.2 solve really your timeout issue because Cuda seem working ?

i dont know yet… support from xx didnt want to investigate more till i downgrade… unfortunately i backed up the creds from both servers, and the gatewayIDF.json but not the nodeIDF.json so they have to reset me which sucks and i loose days. If this problem should persist even after the downgrade i am kind of mind boggeled.

Yes not forget to backup node json file :frowning:
Gateway json seem self generate with certificate but not node json.
So your registration key should be regenerated ?
Hope new key solve your issue :+1:

It seems not only loosing days… loosing weeks…

Try to ask again for reset your key like that your are up for the next month ! :frowning:
A good node who can’t run :frowning:

Timeout can be an issue with network too and may be not the node or Cuda version…

got it now… i am back online yipiiii… i will never ever install something again that isnt supported by the devs…

1 Like